Payments System Incident
Incident Report for Sertifi
Resolved
This incident has been resolved.
Posted Jan 21, 2023 - 15:11 CST
Identified
We recently identified a system error related to payment processing. We’ve identified the root cause and will provide a resolution as soon as possible.


Thanks,

The Sertifi Support Team
Posted Jan 21, 2023 - 12:21 CST
This incident affected: Payments and Authorizations.